Frontdoor connections are recovering and interviewing works well for most regions. We will keep monitoring the situation.
Posted Oct 29, 2025 - 21:50 UTC
Identified
The issue has been identified and is caused by Azure Front Door. Microsoft is working on a solution. We will continue to monitor the situation.
Posted Oct 29, 2025 - 20:04 UTC
Investigating
We are investigating an issue where styling from templates is not being loaded, resulting in a plain white interface and possibly lacking specific question functionality. more details will follow.
Posted Oct 29, 2025 - 17:47 UTC
This incident affected: Nfield Americas (Online Interviewing), Nfield Europe (Online Interviewing), and Nfield Asia Pacific (Online Interviewing).