Verification is currently underway for the maintenance items.
Posted Jun 15, 2026 - 09:20 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 15, 2026 - 07:20 UTC
Scheduled
We are currently renewing/replacing a subset of our SSL certificates. There is a chance services will be interrupted, we are working hard to keep downtime to a minimum.
Posted Jun 15, 2026 - 07:19 UTC
This scheduled maintenance affected: Nfield Americas (Manager, API, CAPI (Sync) Service, Online Interviewing, Reporting), Nfield Europe (Manager, API, CAPI (Sync) Service, Online Interviewing, Reporting), and Nfield Asia Pacific (Manager, API, CAPI (Sync) Service, Online Interviewing, Reporting).