EU reporting latency

Incident Report for Nfield

Resolved

This incident has been resolved.
Posted Jul 30, 2026 - 06:48 UTC

Update

We are continuing to monitor for any further issues.
Posted Jul 30, 2026 - 06:48 UTC

Monitoring

There is currently some latency in propagating reporting data in the EU region. It can take longer than normal before completed interviews show up in powerbi reports or repositories. We have scaled up where appropriate and are monitoring the situation.

Other regions (APac, AM, China) are not affected.
Posted Jul 29, 2026 - 15:24 UTC
This incident affected: Nfield Europe (Reporting).