SSL issues in EU, AM an APac

Incident Report for Nfield

Resolved

We rolled back to a known good certificate. All services are operational again.
Posted Jun 12, 2026 - 13:23 UTC

Investigating

There is an issue with one of our SSL certificates, affecting multiple services. You may see ERR_CERT_AUTHORITY_INVALID or Gateway error. We are investigating the issue.
Posted Jun 12, 2026 - 12:01 UTC
This incident affected: Nfield Americas (Manager, API, Online Interviewing), Nfield Europe (Manager, API), and Nfield Asia Pacific (Manager, API).