EU Interviewing degraded performance
Incident Report for
Nfield
Resolved
Azure Fontdoor issues are under control and CDN latency is decreasing.
Posted
Oct
09
,
2025
-
16:50
UTC
Investigating
There is currently an issue in Azure Frontdoor in Europe that can affect performance of interviews. Mitigation is ongoing.
Posted
Oct
09
,
2025
-
11:50
UTC
This incident affected: Nfield Europe (Online Interviewing).
×
Subscribe to Incident
Subscribe to updates for
EU Interviewing degraded performance
via . You'll receive .